PersianAdmins

فروش کابل شبکه

 
 
«متکلم را تا کسی عیب نگیرد سخنش صلاح نپذیرد»
 
 
 
 
محل کنونی شما: مقالات آموزشی سیسکو
 
 

«ذکر نام نویسنده و سایت برای استفاده از مقالات ضروریست،حتی شما دوست عزیز!»

 
 
 
 

سیسکو

راه اندازی Etherchannel بر روی سوییچ های سیسکو

فرستادن به ایمیل چاپ مشاهده در قالب PDF

لینک های Ethernet با استاندارد های متفاوت معرفی شده اند که مشخصات متفاوتی دارند. یکی از مهمترین مشخصات آن که انگیزه پیشرفت را ایجاد کرده همواره سرعت آنها بوده است. Ethernet در حال حاضر با استاندارد های 10M,100M,1000M و 10G موجود است که طبیعتا برای لینک های با پهنای باند بیشتر میبایست هزینه بیشتری برای تجهیزات و لینک های ارتباطی متحمل شد. علاوه بر هزینه ممکن است media ارتباطی نظیر فیبر برای سرعت بالاتر وجود نداشته باشد. پس در موارد نیاز به سرعت بیشتر باید به دنبال راه چاره گشت.
گاهی اوقات ما بین 2 عدد switch یا یک router و یک switch نیاز به برقراری یک ارتباط خطا پذیرداریم. به صورتی که هنگام قطع شدن یکی از لینک های ارتباطی لینک دومی وجود داشته باشد تا در مدار آمده و سرویس دهی را ادامه دهد.
برای پاسخ به مشکلات فوق تکنولوژی Etherchannel ابداع گردید که تحت استاندارد 802.3ad معرفی شده است. این استاندارد اتصال دو switch را توسط دو الی هشت لینک ارتباطی ممکن می سازد. در ابتدا شرکت سیسکو Etherchannel زا با پروتکل Port Aggregation Protocol عرضه کرد و پس از آن IEEE استاندارد 802.3ad با نام Link Aggregation Control Protocol معرفی نمود. PAgP تنها بین تجهیزات سیسکو قابل استفاده است و PACP به صورت استاندارد در ما بقی تجهیزات کاربرد دارد. لازم به ذکر است که تجهیزات سیسکو نیز از PACP پشتیبانی میکنند.


نحوه توزیع پهنای باند
معیار تقسیم پهنای باند بین لینکها بر اساس موارد زیر است که به صورت دستی میتوان آنها را مشخص نمود.
• Source IP Address
• Destination IP Address
• Source MAC Address
• Destination MAC Address
• Source and Destination IP Address
• Source And Destination MAC Address
• Source TCP/UDP Port (4500,6500 series)
• Destination TCP/UDP Port (4500,6500 series)
• Source and Destination TCP/UDP Port (4500,6500 series)
در Etherchannel ممکن است پهنای باند به صورت یکسان تقسیم نشود. که مقدار سهم هر لینک بستگی به تعداد کل لینکها دارد. جدول زیر مقدار توزیع پهنای باند را در شرایط مختلف توضیح میدهد.

تعداد پورت های فعال

نحوه تقسیم پهنای باند

8

1:1:1:1:1:1:1:1

7

2:1:1:1:1:1:1

6

2:2:1:1:1:1

5

2:2:2:1:1

4

2:2:2:2

3

3:3:2

2

4:4

Etherchannel به صورت پیش فرض پورت اصلی یعنی پورتی که ابتدا ترافیک روی آن فرستاده می شود را مشخص میکند که بر اساس شماره پورت در آن Switch مشخص میگردد که شماره پورت کوچکتر دارای اولویت بالاتر است. در تجهیزات سیسکو میتوان به صورت دستی نیز اولویت هر پورت را مشخص کرد.

حالت های مختلف پورت در Etherchannel
هر پورت میتواند روی یکی از حالت های زیر تنظیم شود:
• Active
• Passive
• Desirable
• Auto
• On
از موارد فوق Active و Passive برای پروتکل PACP, موارد Desirable و Auto برای پروتکل PAgP و حالت on برای هر دو پروتکل قابل استفاده است.
حالت on پورت ها را بدون توجه به آن طرف خط در Etherchannel قرار میدهد.
حالتهای Auto و Passive پورت مورد نظر را در حالت آماده باش قرار میدهد که در صورت نیاز آن طرف, خط در Etherchannel قرار گیرد. که Auto برای پروتکل PAgP و Passive برای پروتکل LACP است.
حالتهای Desirable و Active پورت را وادار به جستجوی تجهیزاتی در آن طرف خط می کند که در صورت امکان وارد Etherchannel شوند. که Desirable برای پروتکل PAgP و Active برای پروتکل PACP است.

اجرای Etherchannel در تجهیزات سیسکو
ابتدا به اجرای Etherchannel با پروتکل PAgP میان دو Switch سیسکو میپردازیم:
در ابتدا باید وارد مد کانفیگ شویم و اینترفیس مورد نظر خود را انتخاب کنیم. باید توجه داشت که تمامی اینترفیس هایی که قرار است در یک Etherchannel قرار گیرند میبایست دقیقا از یک نوع بوده و دارای شرایط و کانفیگ یکسان باشند. به عنوان مثال نمیتوان یک GigabitEthernet را با یک FastEthernet در یک Etherchannel قرار داد.
ابتدا نحوه loadbalance را مشخص میکنیم:


Switch1(config)# port-channel load-balance src-dst-ip

برای راحتی بیشتر و مقدار کانفیگ کمتر از interface range استفاده میکنیم که چند اینترفیس را همزمان با هم تنظیم میکند.

Switch1(config)# interface range fastethernet 0/2, fastethernet 0/18

سپس نوع پروتکل ارتباطی را مشخص میکنیم:

Switch1(config-if)# channel-protocol pagp

و حالت قرار گیری پورت را تعیین میکنیم:


Switch1(config-if)# channel-group 1 mode desirable

حالا به Switch دوم رفته و همین تنظیمات را اعمال میکنیم:


Switch2(config)# port-channel load-balance src-dst-ip
Switch2(config)# interface range Fast 0/3 – 4
Switch2(config-if)# channel-protocol pagp

Switch دوم را در حالت auto قرار میدهیم:


Switch2(config-if)# channel-group 1 mode auto

اکنون دو پورت 2 و 18 switch اول با پورتهای 3 و 4 Switch دوم به صورت Etherchannel در آمده اند که بر اساس IP مبدا و مقصد Frame ها را بین یکدیگر تقسیم میکنند.

حالا دو Switch را در حالت PACP تنظیم میکنیم:

Switch1(config)# interface Fa0/12-13, Fa0/19
Switch1(config-if)# channel-protocol lacp
Switch1(config-if)# channel-group 2 mode active

باید توجه داشت که تمام پورت های یک channel-group باید از یک پروتکل استفاده کنند.

Switch2(config)# interface range Fa 0/22 – 24 
Switch2(config-if)# channel-protocol lacp
Switch2(config-if)# channel-group 2 mode passive

اکنون پورت های 12 و13 و 19 Switch اول با پورتهای 22 و 23 و 24 Switch دوم در یک Etherchannel قرار دارند.
برای اولویت دادن به یکی از پورتها از دستور زیر استفاده میکنیم. اولویت پیش فرض تمام پورتها 32768 است.


Switch2(config)# interface F0/23
Switch2(config-if)# lacp port-priority 100

بعد از تنظیم Etherchannel تمامی پورتها به عنوان یک پورت شناخته میشوند. و با نام po که مخفف Port-channel است میتوانیم به آنها دسترسی داشته باشیم. به عنوان مثال برای تنظیم IP بر روی etherchannel اینگونه عمل میکنیم:


Switch2(config)# interface po2
Switch2(config-if)# ip address 10.0.2.55 255.255.255.0

و در آخر با دستور زیر میتوان از وضعیت پورتها و Etherchannel مطلع شد.


Switch2# show etherchannel 1 summary

 

نگارنده :

شاهین غرقی

Internet Redundancy به کمک IP SLA

فرستادن به ایمیل چاپ مشاهده در قالب PDF

IP SLA یا بعبارت دیگر IP Service Level Agreement یک روش مانیتورینگ در شبکه می باشد . یکی از کاربردهای Internet Redundancy , IP SLA  می باشد .
در ادامه با یک مثال به تشریح IP SLA می پردازیم.
در این سناریو فرض بر این می باشد که توسط دو سرویس دهنده اینترنت یعنی ISP A و ISP B سرویس اینترنت را برای شبکه داخلی سازمان فراهم می کنیم. به صورت پیش فرض ISP A به شبکه سرویس اینترنت می دهد وفقط در صورت قطعی اینترنت ، ISP B بصورت پشتیبان وارد عمل شده و عمل سرویس دهی را انجام می دهد.

نکته: سوالی که ممکن است برای شما مطرح شود این می باشد که آیا این عمل را که تنها با static route و پارامتر Administrative Distance می توان پیاده سازی کرد چه نیازی به استفاده از روش IP SLA می باشد؟


Internet-Router(config)# ip route 0.0.0.0 0.0.0.0 4.4.4.1
Internet-Router(config)# ip route 0.0.0.0 0.0.0.0 5.5.5.1 10

جوابی که می توان به این سوال داد این می باشد که در روش static route و استفاده از روش Administrative Distance فقط زمانی به route بعدی مشابه می رود که قطع فیزیکی داشته باشیم در صورتی که ممکن است ارتباط برقرار نباشد ولی قطع فیزیکی نداشته باشیم.
نکته دیگری که باید توجه داشته باشید این می باشد که روش تعریف IP SLA در ورژن های مختلف IOS با هم فرق دارد و برای اطلاعات بیشتر می توانید به Document ، IOS مربوطه مراجعه نمایید.
حال نوبت به تنظیمات مربوطه می گردد.
برای تعریف IP SLA از دستور مقابل استفاده می کنیم.


Internet-Router(config)# ip sla 1
Internet-Router(config-sla)# icmp-echo 4.2.2.4 source-interface serial 0/0/0
Internet-Router(config-sla-echo)# frequency 3
Internet-Router(config)# ip sla schedule 1 life forever start-time now

برای تعریف IP SLA باید یک Tag به آن اختصاص دهیم که این کار را در خط اول انجام دادیم. سپس برای تست یا یه عبارت دیگر مانیتورینگ برقراری ارتباط از دستور icmp-echo به همراه IP مد نظر که می تواند IP اینترفیس روتر ISP یا یک IPکه توسط ISP قابل route می باشد که در اینجا IP ، DNS اینترنتی یعنی 4.2.2.4 می باشد استفاده کرده ایم. سپس از دستور frequency که برای تکرار این عمل می باشد به کار بردیم مقدار 3 مقابل آن به مفهوم این می باشد که این عمل هر 3 ثانیه یک بار انجام می گیرد مقدار پیش فرض frequency یک دقیقه می باشد . حال که تنظیمات انجام گردیده نوبت به اجرای عمل مانیتورینگ می گردد که این کار با دستور ip sla schedule 1 life forever start-time now که بیان گر اجرای مانیتورینگ با شماره Tag 1 از زمان حال به بعد تا زمانی که خودمان این عمل را متوقف کنیم می باشد.
نکته دیگری که باید به آن توجه کنید این می باشد که IP SLA را نمی توان به جایی به صورت مستقیم assign کرد برای استفاده از IP SLA آن را به شی Track ، assign کرده و Track با توجه به نتیجه مانیتورینگ IP SLA کار خاصی را انجام می دهد.


Internet-Router(config)# track 1 ip sla 1

حال که کلیه تنظیمات انجام شده میبایست شی track را به static route ، assign کنیم ، برای اینکار به روش زیر عمل می کنیم.


Internet-Router(config)# ip route 0.0.0.0 0.0.0.0 5.5.5.1 track 1
Internet-Router(config)# ip route 0.0.0.0 0.0.0.0 4.4.4.1 10

Static route نوشته شده به این صورت عمل می کند که اولین route تا مادامی که نتیجه مانیتورینگ IP SLA که به Track1 وارد می شود مثبت باشد برقرار می باشد در غیر ان صورت route دوم انجام می گیرد.

 

نگارنده :

ایمان ابراهیمی تجدد

i.ebrahimi at hotmail.com

 

موضوعات مشابه :

 Cisco Failover

 

راه اندازی VOIP بصورت محلی و سایت به سایت

فرستادن به ایمیل چاپ مشاهده در قالب PDF

تعریف پروژه :

راه اندازی VOIP بصورت محلی و سایت به سایت.

طرح پروژه :

 دانلود پروژه در قالب نرم افزار Packet tracer

 

تجهیزات مورد نیاز پروژه :

  1. دو عدد روتر 2811
  2. دو عدد ماژول WIC-1T
  3. دو عدد سویچ 2960
  4. چهار عدد IP Phone و دو کامپیوتر
  5. اتصالات (یک اتصال WAN بین دو روتر از نوع سریال و سایر اتصالات از نوع Straight)

 

 مراحل پیاده سازی  :

 برای شروع از تنظیم سویچ ها شروع می کنیم. مراحل تنظیمات هر دو سویچ مانند هم می باشد.


Switch>
Switch>enable
Switch#config terminal
Switch(config)#

ابتدا VLAN های data و voice را ایجاد می کنیم. برای این کار به روش زیر عمل می کنیم.
ایجاد Vlan ها به این دلیل می باشد که ترافیک های voice و data را از هم جدا کنیم این کار باعث عدم تداخل و در نتیجه کیفیت سرویس دهی می شود.
در اینجا vlan 10 را برای Data  و vlan 20 را برای Voice ایجاد می کنیم.

Switch(config)#vlan 10
Switch(config-vlan)#name Data
Exit
Switch(config)#vlan 20
Switch(config-vlan)#name Voice
Exit

حال باید vlan های ساخته شده را به interface های سویچ نسبت دهیم.
برای این کار به روش زیر عمل می کنیم.


Switch(config)#interface range fa 0/1-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#switchport voice vlan 20

 

حال که کار نسبت دادن vlan ها به interface  ها انجام گردیده می بایست پورت Trunk که برای خروج vlan  ها از سویچ استفاده می شود را تنظیم کنیم.
برای این کار به روش زیرعمل می کنیم.


Switch(config)#interface gig 1/1
Switch(config-if)#switchport  mode trunk

کار تنظیمات سویچ به اتمام رسید فقط  در انتها اگر می خواهید تجهیزات پس از اتصال به سویچ بصورت آنی و بدون وقفه به سویچ متصل شوند از دستور زیر استفاده کنید.


Switch(config)# spanning-tree portfast default

حال نوبت به تنظیم روترها می رسد، مراحل کلی تنظیم هر دو روتر مانند هم می باشد. البته کمی با هم تفاوت دارد.
تنظیمات  را از روتر یک شروع می کنیم.
ابتدا  ماژول WIC-1T را به روتر اضافه می کنیم این ماژول اینترفیس لازم جهت اتصال بصورتwan   ،برای برقراری ارتباط با روتر دو را فراهم می کند.
برای این کار به قسمت Physical رفته و سپس مانند مراحل زیرعمل می کنیم.

  1.  برای اضافه کردن هرگونه ماژول ابتدا باید روتر را خاموش کنیم.
  2. ماژول WIC-1T را از قسمت ماژول ها انتخاب کرده و در slot مربوط به WIC(Wan Interface Card) قرار می دهیم.
  3. سپس مجددا روتر را همانند مرحله اول  با زدن دکمه پاور روشن می کنیم.

 

حال که این ماژول اضافه شد می توانیم کار تنظیمات را ادامه دهیم.
ابتدا هرسویچ را به روتر متصل می کنیم
برای این کار پورت gig 1/1  سویچ را که بصورت Trunk  تنظیم کردیم را به پورت Fa 0/0 روتر با کابل  از نوع straight متصل می کنیم.
حال نوبت به تنظیمات می باشد که به روش زیر عمل می کنیم.
وارد محیط config می شویم.


Router1>
Router1>enable
Router1#config terminal
Router1(config)#

حال به تنظیم interface fa0/0 می پردازیم
چون پورت سویچ بصورت Trunk است پس باید پورت روتر را به صورت Sub interface تعریف کنیم تا عمل routing بین vlan های مختلف انجام گیرد.


Router1(config)#interface fa 0/0
Router1(config-if)# no shut
Router1(config-if)#exit
Router1(config)#interface fa 0/0.10
Router1(config-subif)# encapsulation dot1Q 10
Router1(config-subif)# ip address 192.168.10.1 255.255.255.0
Router1(config-subif)#exit
Router1(config)#interface fa 0/0.20
Router1(config-subif)# encapsulation dot1Q 20
Router1(config-subif)# ip address 192.168.20.1 255.255.255.0

حال نوبت به تنظیم DHCP برای تخصیص IP به تجهیزات می باشد.
توجه داشته باشید با توجه به اینکه دو vlan متفاوت داریم در نتیجه باید دو رنج مختلف IP به آنها تخصیص دهیم.
نکته : تخصیص option 150 برای معرفی سرور TFTP به تجهیزات می باشد.


Router1(config)#
Router1(config)#ip dhcp pool voice
Router1(dhcp-config)#network 192.168.20.0 255.255.255.0
Router1(dhcp-config)#defualt-router 192.168.20.1
Router1(dhcp-config)#option 150 ip 192.168.20.1
Exit
Router1(config)#
Router1(config)#ip dhcp pool pcs
Router1(dhcp-config)#network 192.168.10.0 255.255.255.0
Router1(dhcp-config)#defualt-router 192.168.10.1
Router1(dhcp-config)#option 150 ip 192.168.10.1
Exit

حال نوبت به تنظیمات telephony service می باشد.
تنظیمات زیر مربوط به تنظیمات راه اندازی cucm express می باشد.


Router1(config)#
Router1(config)#telephony-service
Router1(config-telephony)#max-dn 24
Router1(config-telephony)#max-ephone 24
Router1(config-telephony)# ip source 192.168.20.1 port 2000
Router1(config-telephony)#auto assign 1 to 24

ایجاد شماره تلفن که در اینجا ما سه شماره تلفن در نظر گرفته ایم.


Router1(config)#
Router1(config)#ephone-dn 1
Router1(config-ephone-dn)#number 1000
Router1(config)#ephone-dn 2
Router1(config-ephone-dn)#number 1001
Router1(config)#ephone-dn 3
Router1(config-ephone-dn)#number 1002

نکته: این تنظیمات به صورتی انجام گردیده که شماره تلفن ها به صورت خودکار به IP Phone ها اختصاص یابد. درصورتی که تمایل داشته باشید شماره خاصی رو به IP PHONE  خاصی اختصاص دهید باید از دستور ephone همراه با پارامترهای آن (mac-address و button) استفاده نمایید.
حال اگر به ip phone ها نگاهی بندازید آنها دارای شماره های اختصاص یافته توسط روتر می باشند.

 

 و همچنین می توانید از آنها با یکدیگر تماس بگیرید

 

 حال نوبت به برقرای ارتباط با سایت دیگر که در اینجا مثلا در کشور دیگری می باشد می پردازیم.
برای این کار ارتباط از نوع سریال در نظر گرفته شده است. برای تنظیم آن باید به پورت مورد نظر که در توسط ماژول در ابتدا به روتر اضافه کردیم می رویم.


Router1(config)# interface serial 0/0/0
Router1(config-if)# ip address 10.10.10.1  255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#no shut

دلیل تنظیم clock rate در این اینترفیس بخاطر انتخاب  و اتصال از روتر اول به روتر دوم می باشد(انتخاب روتر اول بعنوان DTE)
تنظیمات روتر دو نیز مانند روتر یک می باشد با کمی تفاوت که در ذیل به آن می پردازیم.
تنظیمات را از روتر یک شروع می کنیم.
ابتدا  ماژول WIC-1T را به روتر اضافه می کنیم این ماژول اینترفیس لازم جهت اتصال بصورت wan  برای برقراری ارتباط با روتر دو را فراهم می کند.
برای این کار به قسمت Physical می رویم،و سپس مانند مراحل زیرعمل می کنیم.

  1. برای اضافه کردن هرگونه ماژول ابتدا باید روتر را خاموش کنیم. برا ی اینکار دکمه پاور را مطابق شکل کلیک می کنیم.
  2. ماژول WIC-1T را از قسمت ماژول ها انتخاب کرده و در slot مربوط به WIC(Wan Interface Card) قرار می دهیم.
  3. سپس مجددا روتر را همانند مرحله اول  با زدن دکمه پاور روشن می کنیم.   

 

حال که این ماژول اضافه شد می توانیم کار تنظیمات را ادامه دهیم.
ابتدا هرسویچ را به روتر متصل می کنیم
برای این کار پورت gig 1/1  سویچ را که بصورت Trunk  تنظیم کردیم را به پورت Fa 0/0 روتر با کابل  از نوع straight متصل می کنیم.
حال نوبت به تنظیمات می باشد که به روش زیر عمل می کنیم.
وارد محیط config می شویم.


Router2>
Router2>enable
Router2#config terminal
Router2(config)#

حال به تنطیم interface fa0/0 می پردازیم
چون پورت سویچ را بصورت Trunk تعریف کرده ایم باید پورت روتر را به صورت Sub interface تعریف کنیم تا عمل routing بین vlan های مختلف انجام گیرد.


Router2(config)#interface fa 0/0
Router2(config-if)# no shut
Router2(config-if)#exit
Router2(config)#interface fa 0/0.10
Router2(config-subif)# encapsulation dot1Q 10
Router2(config-subif)# ip address 172.16.10.1 255.255.255.0
Router2(config-subif)#exit
Router2(config)#interface fa 0/0.20
Router2(config-subif)# encapsulation dot1Q 20
Router2(config-subif)# ip address 172.16.20.1 255.255.255.0

حال نوبت به تنظیم DHCP برای تخصیص IP به تجهیزات می باشد.
توجه داشته باشید با توجه به اینکه دو vlan متفاوت داریم در نتیجه باید دو رنج مختلف IP به آنها تخصیص دهیم.
نکته : تخصیص option 150 برای معرفی سرور TFTP به تجهیزات می باشد.


Router2(config)#
Router2(config)#ip dhcp pool voice
Router2(dhcp-config)#network 172.16.20.0 255.255.255.0
Router2(dhcp-config)#defualt-router 172.16.20.1
Router2(dhcp-config)#option 150 ip 172.16.20.1
Exit
Router2(config)#
Router2(config)#ip dhcp pool pcs
Router2(dhcp-config)#network 172.16.10.0 255.255.255.0
Router2(dhcp-config)#defualt-router 172.16.10.1
Router2(dhcp-config)#option 150 ip 172.16.10.1
Exit

حال نوبت به تنظیمات telephony service می باشد.
تنظیمات زیر مربوط به تنظیمات راه اندازی cucm express می باشد.


Router2(config)#
Router2(config)#telephony-service
Router2(config-telephony)#max-dn 24
Router2(config-telephony)#max-ephone 24
Router2(config-telephony)# ip source 172.16.20.1 port 2000
Router2(config-telephony)#auto assign 1 to 24


ایجاد شماره تلفن که در اینجا ما سه شماره تلفن در نظر گرفته ایم.


Router2(config)#
Router2(config)#ephone-dn 1
Router2(config-ephone-dn)#number 2000
Router2(config)#ephone-dn 2
Router2(config-ephone-dn)#number 2001
Router2(config)#ephone-dn 3
Router2(config-ephone-dn)#number 2002

نکته: این تنظیمات به صورتی انجام گردیده که شماره تلفن ها به صورت خودکار به IP Phone ها اختصاص یابد. درصورتی که تمایل داشته باشید شماره خاصی رو به IP PHONE خاصی اختصاص دهید باید از دستور ephone همراه با پارامترهای آن (mac-address و button) استفاده نمایید.
حال اگه به ip phone ها نگاهی بندازید آنها دارای شماره های اختصاص یافته توسط روتر می باشند.

و همچنین می توانید از آنها با یکدیگر تماس بگیرید

حال نوبت به برقرای ارتباط با سایت دیگر که در اینجا مثلا در کشور دیگری می باشد می پردازیم.
برای این کار ارتباط از نوع سریال در نظر گرفته شده است. برای تنظیم آن باید به پورت مورد نظر که در توسط ماژول در ابتدا به روتر اضافه کردیم می رویم.


Router2(config)# interface serial 0/0/0
Router2(config-if)# ip address 10.10.10.2  255.255.255.0
Router2(config-if)#no shut

حال که هر دو روتر  و سویچ تنظیم شده اند در می یابیم کهVOIP  بصورت local برای هر طرف بدرستی انجام می گیرد ولی بین سایت ها تماس قابل برقراری نمی باشد، برای رفع این مشکل باید ابتدا روتینگ بین دو سایت برقرار گردد و سپس  تنظیمات لازم جهت فرستادن تماس های مربوط به هر سایت به روتر مربوطه انجام گیرد در زیر به  تشریح مراحل آن می پردازیم.
مرحله اول تنظیم روتینگ در روترها: که ما از روش static routing بین سایت ها استفاده می کنیم.
تنظیم روتر یک:


Router1(config)#
Router1(config)#ip route 172.16.10.0 255.255.255.0 serial 0/0/0
Router1(config)#ip route 172.16.20.0 255.255.255.0 serial 0/0/0

تنظیم روتر دوم:


Router2(config)#
Router2(config)#ip route 192.168.10.0 255.255.255.0 serial 0/0/0
Router2(config)#ip route 192.168.20.0 255.255.255.0 serial 0/0/0

مرحله دوم تنظیم دو روتر برای ارسال تماس های بین سایتی به روتر مربوطه می باشد.
تنظیمات روتر اول برای ارسال و برقراری تماس با شماره های رنج 2000 مربوط به روتر دوم


Router1(config)#
Router1(config)#dial-peer voice 2000 voip
Router1(config-dial-peer)#destination-pattern 2...
Router1(config-dial-peer)#session target ipv4:10.10.10.2

تنظیمات روتر دوم برای ارسال و برقراری تماس با شماره های رنج 1000 مربوط به روتر اول


Router2(config)#
Router2(config)#dial-peer voice 1000 voip
Router2(config-dial-peer)#destination-pattern 1...
Router2(config-dial-peer)#session target ipv4:10.10.10.1

حال به بررسی برقراری تماس تلفنی بین دو سایت می پردازیم. نتیجه بیانگر برقراری ارتباط می باشد.

 

نگارنده :

ایمان ابراهیمی تجدد

i.ebrahimi at hotmail.com

 

آموزش های مرتبط :

آموزش تصویری تنظیم Call manager بر روی روتر سیسکو

ارسال خروجی دستورات سیسکو به TFTP

فرستادن به ایمیل چاپ مشاهده در قالب PDF

گاهی نیاز است که خروجی دستورات اجرا شده در سیسکو را برای مستند سازی یا پرینت یا ارسال به پشتبان در یک فایل ذخیره کنید.برای مثال می توانید خروجی دستور show vlan را بصورت زیر به یک سرور TFTP ارسال کنید :

show vlan | tee tftp://persianadmins.ir/vlan.txt

ارسال خروجی دستورات دیگر هم بهمین صورت می باشد.

رضا بهروزی

راه اندازی DHCP Server بر روی روتر ها و سوییچ های سیسکو

فرستادن به ایمیل چاپ مشاهده در قالب PDF

بر روی هر یک از تجهیزاتی که از پروتکل TCP/IP پشتیبانی می کنند به ۲طریق می توان IP Address تنظیم کرد.

  • Static
  • Dynamic

حتما تمامی خوانندگان با روش static آشنایی دارند. همان روش وارد کردن آدرس ها بصورت دستی. این روش را به دلایل زیادی نمیتوان همیشه به کار بست. به عنوان مثال وقتی شما یک شبکه خیلی بزرگ در حد ۵۰۰۰ عدد کامپیوتر دارید یا اگر همانند یک  ISP مشترکین شما دائم عوض می شوند. ممکن است کاربران شما بخواهند بر روی موبایل ها یا tablet ها و یا هر دستگاهی که وارد کردن IP بر روی آنها دشوار است آدرس وارد کنند. و از طرف دیگر وقتی آدرس ها به صورت دستی وارد شود مدیر شبکه هیچ کنترلی بر روی آنها ندارد و ممکن است ۲ نفر یک آدرس مشترک را استفاده کنند.

به همین دلیل بود که در سال ۱۹۹۳ متخصصین امر با نوشتن RFC1531 اولین ورژن (DHCP (Dynamic Host Configuration Proptocol را استارت زدند و در سال ۱۹۹۷ توسط RFC2131 آن را تکمیل کردند.

DHCP پروتکلی است که وظیفه آدرس دهی به صورت اتوماتیک را به کاربران یا تجهیزات بر عهده دارد. که در این آموزش هدف ما پیاده سازی آن بر روی روتر ها و سوئیچ های سیسکو است. که به دلیل کاربردی بودن آموزش از شرح پروتکل آن صرفه نظر کرده و صرفا به راه اندازی آن می پردازیم.

 

 

به صورت پیش فرض DHCP Server بر روی روترهای سیسکو فعال است که در صورت غیر فعال بودن آن با استفاده از دستور زیر می توان آن را فعال کرد:

service dhcp

 

 

برای راه اندازی DHCP Server ابتدا می بایست یک pool ساخته و تنظیمات مربوطه را در آن بنویسیم:

 

ip dhcp pool PersianAdmins

 

 

سپس آن network را که میخواهیم DHCP از آن رنج IP به کاربران اختصاص دهد مشخص می کنیم:

 

network 192.168.33.0 255.255.255.0

یا

network 192.168.33.0 /24

 

سپس آدرس دامین را برای DHCP Server مشخص می کنیم:

domain-name admins.ir

 

و با این دستور آدرس dns server را برای کلاینت ها مشخص می کنیم:

dns-server 8.8.8.8 192.9.9.3

 

اگر DHCP Server شما برای یک شبکه مایکروسافتی نصب می شود, ممکن است نیاز به ست کردن آدرس wins server برای کلاینت ها داشته باشید که با این دستور قابل اجراست:

netbios-name-server 192.168.33.10

 

که نوع wins server می تواند یکی از انواع broadcast, peer-to-peer,  mixed یا hybrid باشد که با این دستور مشخص می شود:

netbios-node-type b-node

 

یکی از مهمترین امکانات DHCP Server ست کردن default gateway برای کلاینت است. که اینگونه می بایست آن را نوشت:

default-router 192.168.3.1

 

و در آخر ماکزیمم میزان زمان اختصاص IP به هر client را مشخص میکنیم که می تواند بر اساس روز, ساعت یا دقیقه باشد:

lease 7

 

هم اکنون Pool ما ساخته شده و باید آن را به یک اینترفیس معرفی کنیم تا کاربران آن اینترفیس خاص بتوانند از این DHCP Server استفاده کنند. برای این کار کافیست فقط روی هر اینترفیسی که میخواهیم از رنج آدرسهای که برای pool خود مشخص کردیم یک آدرس وارد کنیم:

config terminal
Interface Fastethernet 0/3
ip address 192.168.33.1 255.255.255.0

 

با انجام مراحل فوق نصب DHCP Server شما به پایان رسیده است. اما فرض کنید در شبکه یک پرینتر دارید که آدرس آن به صورت دستی وارد شده است. و نمی خواهید هیچ دستگاه دیگری آن آدرس را دریافت کند. پس باید آن آدرس را از لیست آدرس هایی که DHCP Server به کلاینت ها می دهد خارج کنید. که با exclude کردن آن قابل انجام است:(این دستور در مد exec انجام می شود)

config terminal
ip dhcp excluded-address 192.168.3.23

یا

ip dhcp exluded-address 192.168.3.42 192.168.3.45

که در خط اول یک آدرس و در خط دوم چند آدرس را از لیست آدرس ها خارج کردیم.

در شرایطی دیگر تصور کنید یک دوربین تحت شبکه داریم که میبایست همیشه آدرس 192.168.3.20 را از DHCP erver بگیرد. در چنین مواقعی یک pool مجزا ساخته و با تنظیمات زیر آدرس فوق را برای دوربین خود رزرو میکنیم:

 

ip dhcp pool camera
host 192.168.3.20
hardware-address 0024.0106.392F
client-name IP-Camera

 

و در پایان مانند تمامی سرویس های Cisco IOS میتوانیم با دستورات زیر از DHCP Server خود گزارش گرفته و troubleshoot کنیم:

برای مشاهده وضعیت DHCP Server:

 

Router#sh ip dhcp server statistics
Memory usage         25777
Address pools        2
Database agents      0
Automatic bindings   1
Manual bindings      1
Expired bindings     0
Malformed messages   0
Secure arp entries   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           1

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              2
DHCPNAK              0

برای مشاهده تعداد DHCP Pool ها و وضعیت هر کدام:

Router#sh ip dhcp pool

Pool PersianAdmins :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 254
Leased addresses               : 1
Pending event                  : none
1 subnet is currently in the pool :
Current index        IP address range                    Leased addresses
192.168.3.4          192.168.3.1      - 192.168.3.254     1

Pool camera :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 1
Leased addresses               : 1
Pending event                  : none
0 subnet is currently in the pool :
Current index        IP address range                    Leased addresses
192.168.3.20         192.168.3.20     - 192.168.3.20      1

و برای مشاهده آدرس های اختصاص یافته:

Router#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
Hardware address/
User name
192.168.3.3         0100.2401.0639.2f       May 01 2011 05:06 AM    Automatic
192.168.3.20        0012.2345.ffd4          Infinite                Manual

 

نگارنده: شاهین غرقی

منبع:

Cisco.com

حل مشکل err-disabled در سوئیچ های سیسکو

فرستادن به ایمیل چاپ مشاهده در قالب PDF

اگر تجربه کار با catalyst های سیسکو را دارید حتما برایتان پیش آمده که بعضی از پورت های سوئیچ شما ناگهانی  و زیر بار خاموش شود. ممکن است تصور کنید که آن پورت دچار مشکل شده و یا به اصطلاح سوخته است. اما همیشه اینطور نیست.گاهی اوقات خود سوئیچ یک یا چند پورت را برای حفاظت بیشتر به حالت disable می برد. به این تکنولوژی err-disabled  گفته می شود.

لیست سوئیچ های که از err-disabled پشتیبانی میکنند به شرح زیر است:

 

CatOS:

2948G

4000 - 4500

5000 - 5500

6000 - 6500

 

IOS:

2900XL - 3500XL

2940 - 2950 - 2960 - 2970

3550 - 3560 - 3560-E - 3750 - 3750-E

4000 - 4500

6000 - 6500

 

این پیش آمد می تواند یکی از علت های زیر را داشته باشد که هر یک را توضیح داده و نحوه برطرف کردن آن را خواهیم گفت.

  • A cable that is out of specification (either too long, the wrong type, or defective)
  • Duplex mismatch
  • Port channel misconfiguration
  • BPDU guard violation
  • UniDirectional Link Detection (UDLD) condition
  • Late-collision detection
  • Link-flap detection
  • Security violation
  • Port Aggregation Protocol (PAgP) flap
  • Layer 2 Tunneling Protocol (L2TP) guard
  • DHCP snooping rate-limit
  • Incorrect GBIC / Small Form-Factor Pluggable (SFP) module or cable
  • Address Resolution Protocol (ARP) inspection
  • Inline power

اما ابتدا باید به نحوه کشف این خطا بپردازیم.

ساده ترین راه آن مشاهده خاموش بودن پورت است. اما اگر وارد سوئیچ شویم با show گرفتن از آن اینترفیس خاص این خطا را مشاهده میکنیم:

show interface Gigabitethernet 0/23 status

Port    Name       Status       Vlan       Duplex  Speed Type
Gi0/23              err-disabled 100          full   1000 1000BaseSX

 

و راه دیگر آن مشاهده لاگ آن در syslog یا console روتر است که خطایی مشابه این به شما می دهد:

%SPANTREE-SP-2-BLOCK_BPDUGUARD: 
Received BPDU on port GigabitEthernet4/1 with BPDU Guard enabled. Disabling port.
%PM-SP-4-ERR_DISABLE:
bpduguard error detected on Gi4/1, putting Gi4/1 in err-disable state

 

در ابتدا امکان err-disabled برای جلوگیری از collision های خاص طراحی شد اما بعدا به موارد دیگر نیز تعمیم داده شد. که علتهای collision ممکن است زیاد بودن طول کابل یا عدم کیفیت کابل یا یکی نبودن duplex دو طرف باشد. این روزها شرکتهای تولید کابل آلیاژ پائین تری از مس در کابل ها استفاده می کنند. معمولا اگر سوئیچ شما زیر یک دکل بلند نصب باشد و یا اگر از PoE های غیر مرغوب استفاده می کنید حتما دچار چنین مشکلی خواهید شد.

err-disabled به صورت پیش فرض بر روی تمامی سوئیج ها فعال است که  می توان با دستور زیر آن را غیر فعال کرد:

no errdisable cause all

 

  • و اما راه حل آن:

برای حل این مشکل پس از پیدا کردن علت, باید آن را مرتقع سازیم سپس با یکبار غیر فعال و دوباره فعال کردن آن پورت مشکل حل میگردد. که راه بر طرف کردن هر یک از مشکلات به صورت کامل توضیح داده شده است:

در ابتدا err-disabled را در وضعیت recovery قرار میدهیم:

 

errdisable recovery cause all

که دستور فوق میتواند به جای کلمه all هر یک از علل مورد نیاز وارد شود.

پس از اجرای دستور زیر لیست کلیه اینترفیس ها به علاوه علت disable شدن هر یک, به ما نشان داده می شود:

show errdisable recovery

ErrDisable Reason    Timer Status
-----------------    --------------
udld                 Enabled
bpduguard            Enabled
security-violatio    Enabled
channel-misconfig    Enabled
pagp-flap            Enabled
dtp-flap             Enabled
link-flap            Enabled
l2ptguard            Enabled
psecure-violation    Enabled
gbic-invalid         Enabled
dhcp-rate-limit      Enabled
mac-limit            Enabled
unicast-flood        Enabled
arp-inspection       Enabled

Timer interval: 300 seconds

Interfaces that will be enabled at the next timeout:

Interface      Errdisable reason      Time left(sec)
---------    ---------------------    --------------
Fa2/4                bpduguard          273

 

1-عدم تنظیمات صحیح etherchannel

برای تنظیم etherchannel بین 2 سوئیچ حتما میبایست هر دو یا چند پورت درون یک vlan, دارای یک وضعیت trunk مشابه, دارای speed یکسان, دارای duplex یکسان و در کل دارای تنظیمات یکسان باشند. که در غیر اینصورت یک خطا به این شکل در console  ظاهر می شود. که این خطا به علت تنظیم نکردن یکی از سوئیچ ها به عنوان etherchannle رخ داده است پسSTP باعث block کردن ترافیک از یکی از پورتها می شود.

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration 
of Gi4/1

2-عدم رعایت duplex

هر دو اینترفیس 2 دستگاه که به یکدیگر متصل می گردند می بایست بر روی یک duplex یکسان تنظیم شوند. البته در اکثر تجهیزات duplex به صورت اتوماتیک ست شده است که هر حالتی که طرف مقابل باشد خود را تطبیق خواهد داد. امااین خطا زمانی صورت می گیرد که دو طرف نتوانند بر روی یک duplex به توافق برسند. همانطور که میدانید collision متعلق به شبکه های half duplex است و اگر یک طرف half duplex کار کند و طرف دیگر full duplex و به علت اینکه شبکه full duplex تمهیداتی برای جلوگیری از collision نمی بیند شاهد collision در این میان خواهیم بود. البته در شبکه های half duplex ما شاهد درصد کمی collision خواهیم بود که این طبیعی و نا گریز است اما اگر درصد آن بالا رود آنگاه err-disabled وارد عمل خواهد شد. بر خی از علل collision میتواند کارت شبکه غیر مرغوب, کابل بی کیفیت و یا کابل با طول بلند باشد.

 

3-BPDU port gaurd

حتما به این نکته توجه کرده اید که چراغ سوئیچ های سیسکو بر عکس تمامی سوئیچ ها مدتی پس از اتصال کابل نارنجی رنگ و پورت غیر قابل استفاده و بعد از حدود 30 ثانیه سبز شده و میتوان از آن استفاده کرد. علت این اتفاق جلوگیری از پیش آمد loop  در شبکه می باشد. یعنی قبل از up شدن پورت, سوئیچ آن پورت را توسط پروتکل spanning-tree protocol چک می کند. حال ما میتوانیم با فعال کردن قابلیت portfast switching این کار spanning-tree را غیر فعال کرده در نتیجه پورت سریعتر UP شود. اما در این حالت پورت حتما باید به دستگاههای نهایی نظیر کامپیوتر متصل گردد و نباید به دستگاهایی مثل سوئیچ یا بریج وصل شود چرا که در این حالت پورت با پروتکل spanning-tree کنترل نمیگردد اما برای حفاظت BPDU port guard روی آن فعال است که BPDU port gaurd در صورت مشاهده loop در این پورت, پورت را به حالت eer-disabled می برد.

برای رفع خطای err-disabled که به این علت بوجود آمده است. شما باید portfast switching را غیر فعال کرده و یکبار اینترفیس را shut و no shut کنید.

interface fastethernet 2/5
spanning-tree portfast disable
shutdown
no shutdown

 

4- UDLD

Unidirectional link detection قابلیتی است که در سوئیچ های بالای سری 6500 سیسکو قرار دارد. کار این پروتکل تشخیص این است  که ایا میان 2 سوئیچ به هم متصل دستگاه دیگری قرار دارد یا خیر. همچنین این پروتکل در صورت عوض شدن جای tx و rx وارد عمل شده و اینترفیس را به حالت err-disabled می برد. اگر دو دستگاه که به یکدیگر متصلند تنها یک طرف UDLD را فعال کرده باشد پورت به حالت err-disabled می رود. پس وقتی دستگاهی مابین این دو سوئیچ قرار گیرد چون از UDLD پشتیبانی نمیکند هر دو سوئیچ آن پورت را به حالت err-disabled می برند.

 

5-Link-flap error

وقتی که یک اینترفیس به صورت مداوم قطع و وصل شود اصطلاحا به آن Link-flap error می گویند. اما وقتی این رویداد بیشتر از 5 بار در 10 ثانیه اتفاق بیفتد سوئیچ آن پورت را به حالت err-disabled می برد. که علت این اتفاق می تواند اتصالات ضعیف, جنس بد کابل, یا عدم کیفیت GBIC باشد.

 

6-Loopback error

هر سوئیچ دائما یک سری packet به عنوان keepalive به تمامی پورتها ( به استثنای پورتهای فیبر و Uplink) می فرستد. که سوئیچ این کار را برای تشخیص وجود دستگاهی در آن اینترفیس انجام می دهد. حال اگر این keepalive packet ها به خود سوئیچ برگردد به هر علتی, سوئیچ آن پورت را به حالت err-disabled می برد.

 

7-Port security violation

در سوئیچ های سیسکو امکانی به اسم port security وجود دارد. با این قابلیت می توان مشخص کرد که چه MAC Address هایی به یک اینترفیس اجازه ارسال ترافیک دارند. حال اگر به یک پورت MAC Addressi به غیر MAC اجازه داده شده وارد شود, سوئیچ این پورت را به حالت err-disabled می برد و همچنین اگر یک MAC Address مجاز به پورت دیگری از سوئیچ که در همان VLAN پورت اول است متصل شود. باز هم به حالت err-disabled می رود.

 

8-L2pt guard

وقتی بخواهیم بین 2 شبکه بزرگ که از طریق یک روتر به هم متصلند, یک ارتباط لایه 2 داشته باشیم باید یک تانل لایه 2 میان این دو شبکه بر قرار کنیم. ما در شبکه خود یک tag بر روی پکت ها توسط پروتکل 802.1q می زنیم. اما برای ارسال آن به یک شبکه دیگر می بایست یک tag دیگر علاوه بر اولی بر روی پکت ها بخورد. که این tag دوم توسط تانل لایه 2 صورت می گیرد. این تانل لایه 2 به صورت اتوماتیک MAC Address مقصد را به 01-00- 0c-cd-cd-d0 عوض می کند.

حالا اگر در شبکه مقصد از هر اینترفیس دیگری یک پکت با این مقصد وارد شود, آن پورت به حالت err-disabled می رود.

 

9-Incorrect SFP cable

زمانی که قصد اتصال 2 سوئیچ 3560 یا یک سوئیچ 3560 با یک 3750 را داریم اگر از کابل CAB-SFP-50CM استفاده کنیم که یک تکه فیبر 50 سانتی متری با کانکتور SFP است اینترفیس های ما به حالت err-disabled می رود. از این کابل به علت کاهش هزینه ها استفاده می شود که کابل مسی را می توان جایگزین آن کرد.

 

10- 802.1x Security Violation

زمانی که از پروتکل 802.1x برای احراز هویت MAC address بر روی سوئیچ های سیسکو استفاده می کنیم اگر یک پورت خاص در حالت single-host تعریف شده باشد و سوئیچ دو MAC Address روی آن پورت مشاهده کند, آن پورت را به حالت err-disabled می برد. که برای حل این مشکل مثلا وقتی که آن اینترفیس به یک IP Phone یا Access Point متصل است می توانیم آن اینترفیس را در حالت Multidomain Authentication  قرار دهیم.

 

 

پس از حل کردن هر کدام از مشکلات فوق با یک بار Shutdown و no Shutdown کردن آن پورت, پورت به حالت عادی بر میگردد.

ما نیز می توانیم با فعال کردن errdisable recovery و مشخص کردن مدت زمان معین که به صورت پیش فرض 300 ثانیه است به صورت اتوماتیک پورت ها را از حالت err-disabled  خارج کنیم.

errdisable recovery interval 400

 

نگارنده: شاهین غرقی

راه اندازی ssh در سیسکو

فرستادن به ایمیل چاپ مشاهده در قالب PDF

یکی از متداولترین روش های اتصال به سخت افزارهای سیسکو استفاده از پروتکل telnet می باشد. حتما با telnet آشنایی دارید.
یک پروتکل که عموما برای مدیریت و کنترل سخت افزار ها از راه دور استفاده می شود. این پروتکل اطلاعات را به صورت clear text میان سرور و کلاینت عبور میدهد, که این امر باعث نا امنی زیادی می شود. چرا که به راحتی می توان با قرار دادن یک Packet capture مانند Wireshark تمامی Packet های عبوری را مشاهده و از اطلاعات آن سو استفاده کرد. البته روشهایی برای امن کردن آن مانند دسترسی تنها چند کامپیوتر خاص به telnet وجود دارد. اما باز هم نمیتوان امنیت آن را تضمین کرد.
یک راه حل مفید برای جایگزینی telnet استفاده از پروتکل SSH است. SSH یا Secure Shell پروتکلی است که اطلاعات را به صورت کد شده میان سرور و کلاینت رد و بدل میکند.
به صورت پیش فرض این پروتکل در روتر ها و سوئیچ های سیسکو غیر فعال است.

ادامه مطلب

راه اندازی PPPoE Server بر روی سیسکو

فرستادن به ایمیل چاپ مشاهده در قالب PDF

PPPoE چیست؟

PPPoE تمامی خاصیت های یک پروتکل PPP را دارد اما با این خصوصیت که بر روی شیکه Ethernet نیز قابل اجراست. یعنی شما میتوانید ارتباطهایی مانند کانکشن PPTP را بر روی لایه 2 داشته باشید.
این پروتکل توسط اولین ISP با هدف تجاری دنیا یعنی UUNET ابداع شده است که اطلاعات کامل این پروتکل با RFC2516 قابل دسترس است.
معمولا ISP  ها بیشتر از این پروتکل استفاده می کنند, یکی به دلیل isolation آن و دیگری به دلیل نیاز به کمترین تنظیمات سمت مشترک.

ادامه مطلب

صفحه 1 از 4